Mod Archive Forums Mod Archive Forums
Advanced search  

News:

Please note: Your main modarchive.org account will not work here, you must create a forum account to post on the forums.

Pages: [1]   Go Down

Author Topic: Online media player still not working  (Read 185 times)

0 Members and 1 Guest are viewing this topic.

Kasran

  • Tasted the Pie
  • Offline Offline
  • Posts: 1
    • View Profile
Online media player still not working
« on: June 13, 2017, 04:30:18 »

(Hi! First post. I'll introduce myself some other time.)

The online module player for Modarchive isn't working; it seems to load something, but hangs before playing any sound. For reference, I'm trying to listen to Skaven's Bejeweled III suite. Judging by the error logged in Chrome's developer console, it appears to be a problem with libopenmpt or how it was compiled to Javascript:

Code: [Select]
Cannot enlarge memory arrays. Either (1) compile with  -s
TOTAL_MEMORY=X  with X higher than the current value 16777216, (2)
compile with  -s ALLOW_MEMORY_GROWTH=1  which adjusts the size at
runtime but prevents some optimizations, (3) set Module.TOTAL_MEMORY
to a higher value before the program runs, or if you want malloc to return
NULL (0) instead of this abort, compile with  -s ABORTING_MALLOC=0

The fix that someone else posted about doesn't work; it just prints the same error again.

QUICK EDIT: Just tried Captured Sun and Autonomus (what can I say, I've been on a Skaven kick) and they're working fine, with nothing in the dev console except a warning about a deprecated method. So it seems some tracks work, but not others.
« Last Edit: June 13, 2017, 04:38:13 by Kasran »
Logged

Saga Musix

  • TMA Moderator
  • Lerd of the Pies
  • ****
  • Offline Offline
  • Posts: 1961
  • I love OpenMPT! And Modules! And TMA! And Pie! :>
    • View Profile
    • Saga Musix - free mod music and more!
Re: Online media player still not working
« Reply #1 on: June 13, 2017, 13:45:04 »

The fix from that thread is completely unrelated; the module you're trying to play simply requires too much memory to play. That cannot be fixed by a user script, the player needs to be recompiled to allow more memory to be used (in theory it should be set up to allow for dynamic memory allocation, I am not completely sure why that fails). You will have to listen to that particular file offline for now.
« Last Edit: June 13, 2017, 13:57:10 by Saga Musix »
Logged
» My TMA artist profile
» Visit my music site: https://sagamusix.de/ [de, en]
» Visit my programming website: https://sagagames.de/ [de]
» Open ModPlug tracker

Saga Musix

  • TMA Moderator
  • Lerd of the Pies
  • ****
  • Offline Offline
  • Posts: 1961
  • I love OpenMPT! And Modules! And TMA! And Pie! :>
    • View Profile
    • Saga Musix - free mod music and more!
Re: Online media player still not working
« Reply #2 on: June 13, 2017, 15:51:08 »

After recompiling, the file loads now, but you will only hear silence for now because the online player only plays the first subtune (which is a silent pattern). I might have to add a subtune selector to the player.
Edit: Subtune selection is now possible.
« Last Edit: June 13, 2017, 18:39:14 by Saga Musix »
Logged
» My TMA artist profile
» Visit my music site: https://sagamusix.de/ [de, en]
» Visit my programming website: https://sagagames.de/ [de]
» Open ModPlug tracker

nikku4211

  • Needs more Pie
  • Offline Offline
  • Posts: 33
  • Also known as Nikku4212
    • View Profile
    • 1034co site
Re: Online media player still not working
« Reply #3 on: June 13, 2017, 23:57:59 »

Thank you. I hope the online HTML5 player works well on my Chrome browser running in Windows 10.
Logged
Pages: [1]   Go Up