Mod Archive Forums

Music Production => MilkyTracker => Tracking => MilkyTracker Support => Topic started by: j_bins on August 22, 2014, 20:16:03

Title: Small GUI?
Post by: j_bins on August 22, 2014, 20:16:03
I am new to Milky Tracker so forgive me if I am asking the obvious.  ???

I installed Milky Tracker on Linux Mint Cinnamon using the Software Manager.

When I ran Milky Tracker the GUI was really small and there was no option to expand/scale up the window?

Is Milky Tracker meant to be like this? Do i have to change the resolution of my monitor display to reach a workable size?

Title: Re: Small GUI?
Post by: j_bins on August 22, 2014, 21:55:46
OK...I found the settings to change the resolution but when I restarted Milkytracker to implement the new settings everything went into slomo and Mint crashed :(

Now even after uninstalling  and reinstalling Milkytracker the same happens. Maybe there is a settings file that needs deleting that holds the incompatible settings I made?

I have tried:

 sudo apt-get purge milkytracker

but still no luck....ideas?
Title: Re: Small GUI?
Post by: raina on August 29, 2014, 10:53:21
Look for something beginning with .milky in ~/.

There's a scaling setting below the resolution options in Config > Layout.
Title: Re: Small GUI?
Post by: j_bins on September 04, 2014, 17:35:37
Thanks raina,

(I am quite new to Linux) ~/  is the root partition? I am not sure how I can access that?

However I have found a file called .milkytracker_config and opened it in GNU Nano. I have changed the resolution to 800x600 (I think).

I am unsure how to edit the file to change the scale or turn off 'fullscreen'. Any ideas how to edit the config file?


Title: Re: Small GUI?
Post by: j_bins on September 04, 2014, 17:48:54

I have sort of solved it.....

-  uninstalled Milkytracker

- deleted the .milkytracker_config file

- reinstalled milky tracker


Still not sure how to set up scale/resolution/fullscreen layout without encountering the same problem.

(My screen resolution is set to 1400x1050btw)
Title: Re: Small GUI?
Post by: raina on September 05, 2014, 10:24:40
Whoops. ~/ is shorthand for your home directory, looks like it would be /home/[username] on Mint. And / is the filesystem root but you seem to have figured it out anyway. I think only the middle step of your fix is necessary for the same effect.

But for the original issue, try doing this: Start MilkyTracker windowed as you would by default. Then in Config > Layout, hit the Custom button next to the Resolutions title. Enter 700 for the width, and 525 for the height, half of your screen resolution dimensions. Then set the Scale to X2 to bump the thing back up to your screen's (I'm assuming) native resolution. Resolution changes do tend to require a restart, so hit OK on the left and do that.

Now, once restarted, it looks like that 700 pixel width is too narrow to actually show the Full screen option next to the Resolutions list but you should be able to toggle full screen with Alt-Enter. Modern OSes, drivers, video cards and monitors are a bit picky about display modes but I have tried these steps on two Windows machines (7 32-bit, AMD mobile GPU / 7 64-bit, nVidia GPU) with 1920x1080 screens and Milky set to 960x540 X2, and it worked for me.
Title: Re: Small GUI?
Post by: j_bins on September 05, 2014, 19:30:02
Thanks raina for your detailed reply,

I am only just getting my head around Linux so thanks for explaining the root / home thing.

I will try the steps you suggest when I am on my other computer later.

Title: Re: Small GUI?
Post by: j_bins on September 07, 2014, 18:58:18
OK. have set it up as you suggested = Ace :) all is well. Thanks I have to learn how it works  ;)