Mod Archive Forums Mod Archive Forums
Advanced search  

News:

Please note: Your main modarchive.org account will not work here, you must create a forum account to post on the forums.

Pages: 1 [2]   Go Down

Author Topic: [workaround only] Windows Mobile 6 bug ?  (Read 9394 times)

0 Members and 1 Guest are viewing this topic.

starknight

  • Wants more Pie
  • Offline Offline
  • Posts: 5
    • View Profile
Re: Windows Mobile 6 bug ?
« Reply #10 on: April 24, 2008, 10:47:10 »

Ok, using the Windows XP version I created a "milkytracker.cfg" file with a buffer of 371ms (16.3K).

Then I used it with the Windows CE version. It worked fine, no more freezes. Then I started lowering it of small amounts each time. It works with values up to 220ms (9.7K). Any value under 220ms starts freezing the device again.

Such a solution could be acceptable if you only want to listen to some tracks... but it is not accetable if you try to compose something. Hearing a note with a 220ms delay is not that good  :(

Don't know how other apps sorted out this problem but I am sure they do not use such a large buffer (audio is always synced with images in players or with character's actions in games).
Logged

pailes

  • Milkytracker Moderator
  • Pie Rehab
  • *
  • Offline Offline
  • Posts: 287
    • View Profile
Re: Windows Mobile 6 bug ?
« Reply #11 on: April 24, 2008, 11:26:12 »

Well if anyone knows more about the problem and how it could be possible to cope with it I'm always interested. But I could imagine that with games and video players you can find suitable workarounds which would still work even with larger buffers.

Anyways I'm neither a windows mobile expert nor an expert when it comes to the crappy Windows waveOut API ;)
« Last Edit: April 24, 2008, 11:29:30 by pailes »
Logged
Pages: 1 [2]   Go Up