Mod Archive Forums Mod Archive Forums
Advanced search  

News:

Please note: Your main modarchive.org account will not work here, you must create a forum account to post on the forums.

Pages: [1]   Go Down

Author Topic: [no bug] Latency?  (Read 4121 times)

0 Members and 1 Guest are viewing this topic.

cyberf0x

  • Liking the Pie
  • Offline Offline
  • Posts: 2
    • View Profile
[no bug] Latency?
« on: June 22, 2008, 11:09:25 »

Hello

Weird bug with latency. I don't think it's possible to control the latency in SDL, AFAIK it's fixed but I could be wrong (not a day to day programmer). The thing is changing buffer which is directly connected to resulting latency to maximum, changes probably the sleep function of the whole loop which in a weird manner results in a CPU hogging -> GUI hogging. Changing it to mininum doesn't hog the CPU however it affects the latency itself so the 512B-1024B buffer setting is somewhat safe. Looking at Skale tracker latency is set to fixed at max, other similar programs using SDL are talking to other libs like OpenAL  which is nice, or to ALSA directly which is PITA in a sense of programming.
Another problem is with JACK. In my case it doesn't get zombified, it just doesn't work at all :) No sound.
And lastly, is there a way to change the fonts in "menu"? Changing font-face doesn't do a thing. Is the GUI fixed size no matter what the resolution is? :)

cyberf0x
« Last Edit: January 06, 2009, 12:44:05 by m0d »
Logged

Deltafire

  • Milkytracker Moderator
  • Pie Rehab
  • *
  • Offline Offline
  • Posts: 193
    • View Profile
Re: Latency?
« Reply #1 on: June 22, 2008, 12:26:00 »

Ok, a few points you raised there:

SDL Latency
This can be and is controlled by Milkytracker.  Very high latencies cause the GUI to appear sluggish, this is because the song position is updated with every audio buffer generated; there are no sleep loops or similar.

ALSA
Milkytracker does have an ALSA driver (although currently there are some issues caused by failure to recover from buffer underruns on some hardware).

JACK
You probably haven't connected Milkytracker to an audio output client. Milkytracker does not and will not attempt to guess which audio client to connect to, you must connect it yourself using jack_connect, qjackctl or similar.

I think the GUI fonts are fixed..
Logged

cyberf0x

  • Liking the Pie
  • Offline Offline
  • Posts: 2
    • View Profile
Re: Latency?
« Reply #2 on: June 22, 2008, 12:44:00 »

Hello again

Tried JACK but in the QJackCtl I can't connect outputs to inputs, cliking and cliking but no connection :). Tried to refresh it and connect again but nothing happens.
The only fonts I can change are the pattern fonts, I wondered if there is a way to change the "menu" font and to be specific the font size in the font-face section. The font-face changes but the size is still the same.

As for SDL I wanted to ask you about the update but I think I just grab a copy of the source ;)

cyberf0x
Logged

raina

  • Milkytracker Moderator
  • Url of Pieland
  • ***
  • Offline Offline
  • Posts: 718
    • View Profile
    • raina.kapsi.fi
Re: Latency?
« Reply #3 on: June 22, 2008, 17:22:12 »

Only the pattern font size can be changed (with the radio buttons). The faces are freely selectable but the GUI only uses the Tiny and System font sizes.
Pages: [1]   Go Up