Mod Archive Forums Mod Archive Forums
Advanced search  


Please note: Your main account will not work here, you must create a forum account to post on the forums.

Pages: [1]   Go Down

Author Topic: Having trouble building from source on Mac.  (Read 6602 times)

0 Members and 1 Guest are viewing this topic.


  • New User
  • Offline Offline
  • Posts: 3
    • View Profile
Having trouble building from source on Mac.
« on: December 30, 2010, 03:37:46 »


I'm on MacOSX 10.6.5 and have XCode installed.  I tried running ./configure with the defaults but no matter which version of libzzip I compiled, I couldn't get the configure script to recognize it.

I tried patching the file with no_zziplib_dep.patch from the downloads area and that got the configure script to run.  Now it complains that the AM_PATH_ALSA macro is not defined.  I'm on a Mac so I obviously don't have ALSA installed.  I want to use SDL's audio for now and maybe port it to AmigaOS later on based on the source on OS4Depot using the AHI drivers.

I don't need the full editor since I have a binary for that on my Mac.  I just need the player code to work for now so I can make my modifications and maybe send them back upstream.

Thanks for any help,



  • Milkytracker Moderator
  • Rising Star
  • *
  • Offline Offline
  • Posts: 196
    • View Profile
Re: Having trouble building from source on Mac.
« Reply #1 on: December 31, 2010, 00:18:07 »

Just to clarify: There is a PocketPC application called 'MilkyPlay' (which this sub-forum refers to).  The player code within Milkytracker is also called milkyplay, just to confuse ;)

The configure scripts are for building the SDL version of Milkytracker on Posix-compatible platforms.  The native OSX build of Milkytracker does not use these; instead the XCode project files in the 'platforms/osx' directory are used.
Pages: [1]   Go Up