Mod Archive Forums Mod Archive Forums
Advanced search  

News:

Please note: Your main modarchive.org account will not work here, you must create a forum account to post on the forums.

Pages: [1]   Go Down

Author Topic: schism tracker c00 small problem  (Read 139 times)

0 Members and 1 Guest are viewing this topic.

clear2ooo

  • New User
  • Offline Offline
  • Posts: 11
    • View Profile
schism tracker c00 small problem
« on: March 30, 2024, 21:21:33 »

schism tracker

i found a bug with schism. but i cannot reproduce it now. or show anyone what happened. i could only describe what happened to me.

i ran on endeavouros, based on arch linux, budgie desktop, "galileo" release. i use 20240129 application version. don't tell me to use latest version. because "changelog" in github has nothing about what i'm about to say.

sometimes the player ignores "c00" command.

i create song. without instruments because this program is annoying about it. at beginning i have one pattern. which has four "sb1" commands. _w_i_t_h_o_u_t_ "sb0" that should match each loop definition. each pattern loop is at least two beats long. this one pattern became 10 patterns. while i develop the song i play back pressing "f7" key. sometimes i have play back start from song beginning.

then finally i create pattern which has the "c00". i go to "f11" screen and put this pattern first. before the ones with pattern loops. i play back song from beginning. i notice weird behavior which might be expected from impulse tracker. there are no "sb0" whatsoever. so every other pattern, right at the first "sb1", it gives up playing the rest of the pattern. just skips to the next one. which processes the pattern loops correctly.

then suddenly i play back from beginning again. player ignores "c00" command. i put this on line 47 on pattern 0-63 of lines. this is first pattern of the song. it is played entirely. it's supposed to play 3 bars only.

later i was forced to put "sb0" at places where a pattern loop begins. the song plays correctly after that. related to pattern loops. but "c00" thing remained. i quit schism. start it again and it behaves normally again.

it's no use providing "it" suffix file. because it is over 5 mib, i have to make severe cutbacks. the song is not ready for release yet.

i forgot to mention. tracker speed of 5. no commands on patterns.


i am clear2ooo. i am string space. nothing else.
« Last Edit: March 30, 2024, 22:00:35 by clear2ooo »
Logged
Pages: [1]   Go Up