Mod Archive Forums Mod Archive Forums
Advanced search  

News:

Please note: Your main modarchive.org account will not work here, you must create a forum account to post on the forums.

Pages: 1 [2] 3   Go Down

Author Topic: 0.4 corrupting samples?  (Read 21682 times)

0 Members and 1 Guest are viewing this topic.

0xtob

  • NitroTracker Moderators
  • Pie Addict
  • Offline Offline
  • Posts: 84
    • View Profile
Re: 0.4 corrupting samples?
« Reply #10 on: August 03, 2008, 23:04:17 »

darkbluedrew: Glad you got it to work! It seems like your card was auto-patching NitroTracker with a broken DLDI, and deleting it disabled auto-patching, so the correct DLDI that you patches NitroTracker with was used.

People: You could try disabling auto-DLDI-patching and using the Acekard+ DLDI patch. Or Maybe writing only works if run from SD Card instead of the internal NAND.
Logged

remouk

  • Liking the Pie
  • Offline Offline
  • Posts: 4
    • View Profile
Re: 0.4 corrupting samples?
« Reply #11 on: August 04, 2008, 16:12:15 »

Just to let you know, I have the same problem here.

- DS Linker with internal flash memory
- NitroTracker patched with the "NEO Flash MK5 (NAND Flash)" DLDI file, as I usually do
Logged

0xtob

  • NitroTracker Moderators
  • Pie Addict
  • Offline Offline
  • Posts: 84
    • View Profile
Re: 0.4 corrupting samples?
« Reply #12 on: August 16, 2008, 02:56:17 »

OK, the thing is: In the old days, chishm's FAT driver couldn't do non-aligned writes. They would result in noise samples (the same that some of you are experiencing). So, I added a buffer to my XM writing routine such that all writes would be aligned and samples would save fine. With the advent of DLDI, I thought the alignment problems were solved and I removed the buffer because it cluttered up the code. I tested XM writing on my hardware which works fine.

Judging from this thread it seems that some DLDI drivers are buggy in that they do not support unaligned writes. If you have this problem, please complain to your card manufacturer or whoever wrote the DLDI driver and have them fix it, or even better, fix it yourself if the DLDI source is available and make the DLDI available.

But since I don't think any flash card manufacturer will actually care, I'll add the wite buffer to the XM saving routine again so you can save uncorrupted XMs regardless of whether or not your driver can write unaligned. I have no time for NT coding at the moment, and I cannot promise a date for this fix, but you won't have to wait until 0.5 :)
Logged

remouk

  • Liking the Pie
  • Offline Offline
  • Posts: 4
    • View Profile
Re: 0.4 corrupting samples?
« Reply #13 on: August 27, 2008, 18:40:11 »

Thanks for your detailed answer! Can't wait for the new version(s).
Logged

eventide

  • Tasted the Pie
  • Offline Offline
  • Posts: 1
    • View Profile
Re: 0.4 corrupting samples?
« Reply #14 on: October 13, 2008, 07:36:20 »

Hi there,

Can anybody tell me, which combination of nitrotracker and hardware module will work
without this problem? I want to buy a new module.

Thanks in advance!

Eventide.
Logged

werto

  • Wants more Pie
  • Offline Offline
  • Posts: 6
    • View Profile
Re: 0.4 corrupting samples?
« Reply #15 on: October 17, 2008, 09:17:33 »

Hi there,

Can anybody tell me, which combination of nitrotracker and hardware module will work
without this problem? I want to buy a new module.

Thanks in advance!

Eventide.


Yo Eventide :)
here's a cool link all for you:

http://nitrotracker.tobw.net/index.php?cat_id=4#compatibility

wish you'll solve your problem :)

see ya'
peace and love
werto

ps:there's no DSTT in list, but i can say you that it works very fine with it (with the last two kernel :) ).
Logged

john amino

  • Wants more Pie
  • Offline Offline
  • Posts: 5
    • View Profile
Re: 0.4 corrupting samples?
« Reply #16 on: March 25, 2009, 14:21:13 »

I have this problem....and i can't fix it. its driving me insane

does anyone have a version of 0.3 they could send me?
Logged

john amino

  • Wants more Pie
  • Offline Offline
  • Posts: 5
    • View Profile
Re: 0.4 corrupting samples?
« Reply #17 on: March 25, 2009, 14:25:50 »

scrap that.....i need 0.4 working.

ARGH!

can anyone help? i was intending to use Nitrotracker in a live set in a few weeks

i'm using R4DS and DLDI Drop to do the patching.
Logged

john amino

  • Wants more Pie
  • Offline Offline
  • Posts: 5
    • View Profile
Re: 0.4 corrupting samples?
« Reply #18 on: March 25, 2009, 14:51:14 »

...or post me up the details of your set up that work without this problem

cheers

xx
Logged

john amino

  • Wants more Pie
  • Offline Offline
  • Posts: 5
    • View Profile
Re: 0.4 corrupting samples?
« Reply #19 on: March 26, 2009, 12:27:10 »

come on people!

someone must have at least a working set up they can share with me....you can't all be suffering from this bug??

just the card and the patch
Logged
Pages: 1 [2] 3   Go Up