Mod Archive Forums Mod Archive Forums
Advanced search  

News:

Please note: Your main modarchive.org account will not work here, you must create a forum account to post on the forums.

Pages: [1]   Go Down

Author Topic: [need more info] RAM usage bug.  (Read 5270 times)

0 Members and 1 Guest are viewing this topic.

NightSprinter

  • Tasted the Pie
  • Offline Offline
  • Posts: 1
    • View Profile
[need more info] RAM usage bug.
« on: October 25, 2008, 18:08:25 »

Hey there.  I've noticed that sometimes if I manage to load a song or sample that is too large for the available RAM in the DS, it takes up all the available RAM and will not free up if I load another song or zap the entire song (patterns, instruments/samples).  Anyone else having this error?
« Last Edit: September 02, 2009, 14:17:06 by m0d »
Logged

0xtob

  • NitroTracker Moderators
  • Pie Addict
  • Offline Offline
  • Posts: 84
    • View Profile
Re: RAM usage bug.
« Reply #1 on: October 25, 2008, 19:35:28 »

Sounds like the momory check is failing and loaded data overwrites the allocation table. Can you give me a song where this happens?
Logged

The Onyxmizer

  • Needs more Pie
  • Offline Offline
  • Posts: 39
    • View Profile
Re: RAM usage bug.
« Reply #2 on: December 26, 2008, 18:04:55 »

same thing happens to me. I just save and turn off the DS. :|
Logged

zoikkis

  • Needs more Pie
  • Offline Offline
  • Posts: 30
    • View Profile
Re: [need more info] RAM usage bug.
« Reply #3 on: April 07, 2010, 14:06:57 »

I have also seen this happen. I ported this to the issue tracker and also added that NT may completely freeze if RAM gets full.

http://code.google.com/p/nitrotracker/issues/detail?id=10
Logged
Pages: [1]   Go Up