Mod Archive Forums Mod Archive Forums
Advanced search  

News:

Please note: Your main modarchive.org account will not work here, you must create a forum account to post on the forums.

Pages: [1]   Go Down

Author Topic: delay - latency when hitting a key  (Read 3425 times)

0 Members and 1 Guest are viewing this topic.

durk

  • Wants more Pie
  • Offline Offline
  • Posts: 6
    • View Profile
delay - latency when hitting a key
« on: December 10, 2008, 08:10:55 »

Heya,

I've been comparing trackers on PC for a while and finally Milky is what I need and want.

BUT, it's running so damn slow on my computer... When I hit a key, the sample plays after like 1/2 or 1 second. Horrible to compose and test melodies...

What can I do? I don't like the other trackers.

My config is 1,1GHz and XP.
Logged

raina

  • Milkytracker Moderator
  • Url of Pieland
  • ***
  • Offline Offline
  • Posts: 718
    • View Profile
    • raina.kapsi.fi
Re: delay - latency when hitting a key
« Reply #1 on: December 10, 2008, 11:23:59 »

Use the Config, durk. By default, Milky uses these compatible sound settings so that it will work out of the box everywhere. This means using the slow WaveOut driver with a generous buffer setting on Windows. In Config > I/O, try changing your sound driver to DirectSound and reducing the buffer size until you get a better response time but don't go too low so that the sound starts crackling.

To further improve the response time on your setup would be using the ASIO driver which allows using even smaller buffer. On a faster machine the difference might not be that big but here this can help. You either need your sound card to support ASIO or if it doesn't (integrated sound chips, SoundBlaster cards..), you can download and install ASIO4ALL to emulate it. After installation, you should be able to select the ASIO driver in Milky.
« Last Edit: December 10, 2008, 11:26:49 by raina »
Logged

jivatma

  • Needs more Pie
  • Offline Offline
  • Posts: 36
    • View Profile
Re: delay - latency when hitting a key
« Reply #2 on: December 10, 2008, 11:25:43 »

Hello durk,

You can try to change the settings in the Config section in Milkytracker :). To do so, click at "Config" and after that on "I/O". There you can try to set a lower Buffersize if needed. And please try to change the Driver if possible.

The other thing, that might help, is, to select no interpolation or only the linear interpolation and a lower samplerate.  8)

Hope it helps,
Ingo

PS: heheh, you were faster, raina :D
Logged

durk

  • Wants more Pie
  • Offline Offline
  • Posts: 6
    • View Profile
Re: delay - latency when hitting a key
« Reply #3 on: December 10, 2008, 13:56:37 »

Thanks guys!   :angel:

I will try it as soon as I get home.
Logged

durk

  • Wants more Pie
  • Offline Offline
  • Posts: 6
    • View Profile
Re: delay - latency when hitting a key
« Reply #4 on: December 10, 2008, 21:18:44 »

That did the trick, thanks!
Logged
Pages: [1]   Go Up