Mod Archive Forums Mod Archive Forums
Advanced search  

News:

Please note: Your main modarchive.org account will not work here, you must create a forum account to post on the forums.

Pages: [1] 2   Go Down

Author Topic: Bugs in MilkyTracker v0.90.80 (win98 Version)  (Read 10280 times)

0 Members and 1 Guest are viewing this topic.

dbz

  • Devouring the Pies
  • Offline Offline
  • Posts: 10
    • View Profile
Bugs in MilkyTracker v0.90.80 (win98 Version)
« on: February 20, 2009, 23:22:20 »

I don't know if anyone else has experienced these same problems, but I've found that:

1) When a song loops (finishes playing and starts again), some songs play ok, but other songs have no volume on every track - nothing plays until you stop and start the song again.

2) MilkyTracker hangs/freezes when I go to exit the program and the only way to get out of it is to kill the program's process from the task manager. This even occurs if I just start the program, don't load any songs whatsoever - do nothing in fact, and then try and close the program.

I'm running Windows 98SE.
« Last Edit: February 20, 2009, 23:33:51 by dbz »
Logged

Category

  • Wants more Pie
  • Offline Offline
  • Posts: 5
    • View Profile
    • Category - uk.geek.core FULL ALBUM DOWNLOAD
Re: Bugs in MilkyTracker v0.90.80 (win98 Version)
« Reply #1 on: February 21, 2009, 00:09:11 »

Is problem #1 because the channels are set to a volume of 00 at the end of the last pattern?

As for #2, I dunno!
Logged

pailes

  • Milkytracker Moderator
  • Pie Rehab
  • *
  • Offline Offline
  • Posts: 287
    • View Profile
Re: Bugs in MilkyTracker v0.90.80 (win98 Version)
« Reply #2 on: February 21, 2009, 09:19:57 »

Try DirectSound output.
Logged

dbz

  • Devouring the Pies
  • Offline Offline
  • Posts: 10
    • View Profile
Re: Bugs in MilkyTracker v0.90.80 (win98 Version)
« Reply #3 on: February 23, 2009, 23:37:36 »

It may be that the track volumes are being set to zero at the end of the song, but shouldn't the program reset them at the start of the song to initial values or something? Also, I am using DirectX for playback. Any ideas as to why MilkyTracker hangs when I close the program? I'd be happy to have that fixed, if nothing else.
Logged

raina

  • Milkytracker Moderator
  • Url of Pieland
  • ***
  • Offline Offline
  • Posts: 718
    • View Profile
    • raina.kapsi.fi
Re: Bugs in MilkyTracker v0.90.80 (win98 Version)
« Reply #4 on: February 24, 2009, 11:34:46 »

There are no track/channel volumes but if you are talking about global volume, no, the tracker shouldn't reset it on its own at any point during playback.
« Last Edit: February 24, 2009, 11:39:49 by raina »
Logged

pailes

  • Milkytracker Moderator
  • Pie Rehab
  • *
  • Offline Offline
  • Posts: 287
    • View Profile
Re: Bugs in MilkyTracker v0.90.80 (win98 Version)
« Reply #5 on: February 25, 2009, 12:35:50 »

It may be that the track volumes are being set to zero at the end of the song, but shouldn't the program reset them at the start of the song to initial values or something? Also, I am using DirectX for playback. Any ideas as to why MilkyTracker hangs when I close the program? I'd be happy to have that fixed, if nothing else.

The main volume is reset when you force a stop operation (e.g. press stop button).

As for the hang, can't really help you there. MilkyTracker depends on a 3rd party audio library which provides the DirectSound support. It never hanged for me, although there is delay when exiting the program when using DirectSound.
Logged

dbz

  • Devouring the Pies
  • Offline Offline
  • Posts: 10
    • View Profile
Re: Bugs in MilkyTracker v0.90.80 (win98 Version)
« Reply #6 on: March 02, 2009, 17:27:04 »

I wasn't really thinking of the global volume, but since stopping the song corrects the issue (resets the volume) then why not have the program do the same thing automatically at the start of the song?

I don't know, but I was thinking that the freezing problem might have something to do with the file browser. It's just a hunch, because I know that explorer really lags and looks like it has hung if there are lots of directories or files. Maybe I'm totally off course here, but it might be something to look into.

Thanks for all the feedback by the way.

I forgot to mention...
When I discovered that it was hanging I went to use the previous version to see if it was ok, since I didn't remember ever seeing the problem with it. Then I realized I had deleted the previous release. So I redownloaded it after scouring the net for it (maybe there could be previous versions up for download on milkytracker.net?), and sure enough it doesn't have the bug. Version 0.90.60 doesn't hang on exiting the program. I know there have been a lot of changes between it and v0.90.80, but it's a starting point at least. Hope that helps in tracking down the problem.
« Last Edit: March 02, 2009, 17:43:04 by dbz »
Logged

pailes

  • Milkytracker Moderator
  • Pie Rehab
  • *
  • Offline Offline
  • Posts: 287
    • View Profile
Re: Bugs in MilkyTracker v0.90.80 (win98 Version)
« Reply #7 on: March 02, 2009, 18:32:27 »

I wasn't really thinking of the global volume, but since stopping the song corrects the issue (resets the volume) then why not have the program do the same thing automatically at the start of the song?

Simply because of FT2 heritage. And also because the actual play function is too generic to simply make it reset the volume, this would break too many things at once.

I don't know, but I was thinking that the freezing problem might have something to do with the file browser. It's just a hunch, because I know that explorer really lags and looks like it has hung if there are lots of directories or files. Maybe I'm totally off course here, but it might be something to look into.

As I said, DirectSound is a 3rd party library and we switched with a major version from (3 to 4) in which the DirectSound support has basically been reprogrammed from scratch. But wait, I might be able to offer you a version of MilkyTracker having RtAudio3 support too.
« Last Edit: March 02, 2009, 18:36:53 by pailes »
Logged

raina

  • Milkytracker Moderator
  • Url of Pieland
  • ***
  • Offline Offline
  • Posts: 718
    • View Profile
    • raina.kapsi.fi
Re: Bugs in MilkyTracker v0.90.80 (win98 Version)
« Reply #8 on: March 02, 2009, 20:40:53 »

I wasn't really thinking of the global volume, but since stopping the song corrects the issue (resets the volume) then why not have the program do the same thing automatically at the start of the song?

It may well be that a song start on the second time (and then on) is just the beginning of a loop, which may be different from actual song start. I'm talking about sounds and settings that aren't initialized the first time the song plays but then when the song loops, they are. When this is done on purpose, messing with the playback would break those songs.

dbz

  • Devouring the Pies
  • Offline Offline
  • Posts: 10
    • View Profile
Re: Bugs in MilkyTracker v0.90.80 (win98 Version)
« Reply #9 on: March 03, 2009, 02:07:45 »

Ok I think I understand the volume situation now.
Too bad they didn't deal with it properly in FastTracker.

Pailes that would be great, if it's not too much trouble.
Logged
Pages: [1] 2   Go Up