Mod Archive Forums Mod Archive Forums
Advanced search  

News:

Please note: Your main modarchive.org account will not work here, you must create a forum account to post on the forums.

Pages: [1]   Go Down

Author Topic: Modplug MOD trouble  (Read 3262 times)

0 Members and 1 Guest are viewing this topic.

forestknight25

  • Liking the Pie
  • Offline Offline
  • Posts: 2
    • View Profile
Modplug MOD trouble
« on: May 19, 2009, 00:46:16 »

I use Modplug for my tracking projects. However, I would always use IT and XM formats, because 3 problems arise when using Modplug to create MODs (though one of the problems isn't Modplug-specific.)

First-off, I notice the samples are all distorted and stretched out, playing back veeeeery slowly when previewed and/or played in the channels. Yet when I change the pitch up to a listenable level so I can actually USE the tracker, when I play back the MOD in another player, it sounds all off-key and high-pitched.

The second problem is more straightforward, I think, and arises with S3M files as well. When playing back the song/samples it plays only through one stereo channel, all lopsided and imbalanced.

Finally, here's the non-Modplug specific question. When browsing my collection of old MODs using Modplug, I noticed the average size for most of these MODs was VERY small, generally 90 to 98 kilobytes, with the 8-bit WAV samples being anywhere from 3 to 12 kb on average. And yet they sound perfect, hardly fuzzy or distorted at all. How on earth do I get similar results?

Help is strongly appreciated.
Logged

barryvan

  • I can't decide if you're adorable or creepy.
  • TMA Moderator
  • Pie Addict
  • Offline Offline
  • Posts: 130
    • View Profile
    • barryvan
Re: Modplug MOD trouble
« Reply #1 on: May 19, 2009, 06:37:44 »

You'll probably be able to get more specific help at the Modplug Forums than here: http://lpchip.com/modplug/

What version of Modplug are you using? Are you still using Modplug, or are you using an OpenMPT version?
Logged
www.barryvan.com.au - design & music

the barryvan compo - Bimonthly inspiration-based compo

barryvan  @ Last.fm

Saga Musix

  • TMA Moderator
  • Too much pie
  • *****
  • Offline Offline
  • Posts: 2188
  • I love OpenMPT! And Modules! And TMA! And Pie! :>
    • View Profile
    • Saga Musix - free module music and more!
Re: Modplug MOD trouble
« Reply #2 on: May 19, 2009, 09:34:23 »

Finally, here's the non-Modplug specific question. When browsing my collection of old MODs using Modplug, I noticed the average size for most of these MODs was VERY small, generally 90 to 98 kilobytes, with the 8-bit WAV samples being anywhere from 3 to 12 kb on average. And yet they sound perfect, hardly fuzzy or distorted at all. How on earth do I get similar results?
Actually, they do sound worse than bigger modules to me. which doesn't mean that they are worse, the sound quality is just not as good.

About your (Open)MPT problem: You might want to increase your "sound card" tab in the setup dialog, the only reason for one-sided playback I could imagine right now would be a very high stereo seperation value together with bad channel pannings in your modules. :P Also, about the other problems, maybe switching the audio device or increasing the latency could help.
Logged
» My TMA artist profile
» Visit my music site: https://sagamusix.de/ [de, en]
» Visit my programming website: https://sagagames.de/ [de]
» Open ModPlug Tracker
Pages: [1]   Go Up