Mod Archive Forums Mod Archive Forums
Advanced search  

News:

Please note: Your main modarchive.org account will not work here, you must create a forum account to post on the forums.

Pages: [1]   Go Down

Author Topic: Missing *a lot* of sourcefiles when trying to compile...  (Read 2506 times)

0 Members and 1 Guest are viewing this topic.

null1024

  • Devouring the Pies
  • Offline Offline
  • Posts: 16
    • View Profile

I'm trying to compile MilkyTracker on OSX 10.2, and when I try to build, I'm missing 8 or so source files, and from the names, they don't seem to be platform specific...
They're pointing to the folder indicated by the other files in the group, it's just the files aren't there...

Btw, I'm missing:
Code: [Select]

Missing file or directory: ../../../src/ppui/RespondMessageBox.cpp
Missing file or directory: ../../../src/ppui/RespondMessageBoxFileSelector.cpp
Missing file or directory: /Users/null1024/Desktop/milky_/src/tracker/PanningSettingsContainer.cpp
Missing file or directory: /Users/null1024/Desktop/milky_/src/tracker/RespondMessageBoxAudioDriverSelector.cpp
Missing file or directory: /Users/null1024/Desktop/milky_/src/tracker/RespondMessageBoxChannelSelector.cpp
Missing file or directory: /Users/null1024/Desktop/milky_/src/tracker/RespondMessageBoxEQ.cpp
Missing file or directory: /Users/null1024/Desktop/milky_/src/tracker/RespondMessageBoxGroupSelection.cpp
Missing file or directory: /Users/null1024/Desktop/milky_/src/tracker/RespondMessageBoxListBox.cpp
Missing file or directory: /Users/null1024/Desktop/milky_/src/tracker/RespondMessageBoxQuickChooseInstrument.cpp
Missing file or directory: /Users/null1024/Desktop/milky_/src/tracker/RespondMessageBoxResample.cpp
Missing file or directory: /Users/null1024/Desktop/milky_/src/tracker/RespondMessageBoxWithValues.cpp
Missing file or directory: /Users/null1024/Desktop/milky_/src/tracker/SampleLoadChannelSelectionHandler.cpp
Missing file or directory: /Users/null1024/Desktop/milky_/src/milkyplay/ChannelMixingDevice.cpp



[edit]
I'm also getting something about "-Wno-switch-enum" not being a supported option...
« Last Edit: June 26, 2009, 01:45:02 by null1024 »
Logged

Deltafire

  • Milkytracker Moderator
  • Pie Rehab
  • *
  • Offline Offline
  • Posts: 193
    • View Profile
Re: Missing *a lot* of sourcefiles when trying to compile...
« Reply #1 on: June 28, 2009, 00:11:51 »

Noone else has mentioned this problem before.  Are you building in XCode?  Do you have the extra .tgz file with the extra files needed for the Windows/OSX versions?

The website appears to be offline at the moment, so I can't check myself.
Logged

null1024

  • Devouring the Pies
  • Offline Offline
  • Posts: 16
    • View Profile
Re: Missing *a lot* of sourcefiles when trying to compile...
« Reply #2 on: June 28, 2009, 05:59:20 »

I was building in Apple's Project Builder. I just upgraded to 10.3 [which runs suprisingly well on a machine with 192 MB RAM in it], so this isn't an issue anymore [I can use the precompiled build now].

And I did have the extra .tgz file, maybe the .pbproj file in there was pointing to things in the wrong places...
Logged
Pages: [1]   Go Up