Mod Archive Forums Mod Archive Forums
Advanced search  

News:

Please note: Your main modarchive.org account will not work here, you must create a forum account to post on the forums.

Pages: [1]   Go Down

Author Topic: Fake note stops?  (Read 4355 times)

0 Members and 1 Guest are viewing this topic.

ant1

  • Devouring the Pies
  • Offline Offline
  • Posts: 16
    • View Profile
    • chiptune most days
Fake note stops?
« on: October 22, 2009, 23:49:37 »

Sorry for asking such a newbie question...

In one song I have made, the note stops appear to be there in Milkytracker, Modplug, and XMplay, but when I play it back in any of these, the note stops are ignored, and the notes continue on where they are meant to stop - which makes my song almost unlistenable!

In another song I have made, the note stops appear to be there in all 3, and the notes stop in Milkytracker and Modplug, but don't in XMplay (and there is a weird volume jump on one instrument, halfway through, only in XMplay).

Both songs are in .xm, and originally made in Modplug.

Does anyone know what is going on? I guess I am doing something wrong?

Thanks in advance!

Logged

m0d

  • Architect v3-4.0b
  • Administrator
  • Lerd of the Pies
  • ****
  • Offline Offline
  • Posts: 1848
  • M0d
    • View Profile
    • http://winter.pics
Re: Fake note stops?
« Reply #1 on: October 23, 2009, 01:45:57 »

Attach the file to a post in a zip :) (see advanced posting options when you reply to this)

assuming it's small enough to fit :)
Logged
The Architect 🤔

Saga Musix

  • TMA Moderator
  • Too much pie
  • *****
  • Offline Offline
  • Posts: 2215
  • I love OpenMPT! And Modules! And TMA! And Pie! :>
    • View Profile
    • Saga Musix - free module music and more!
Re: Fake note stops?
« Reply #2 on: October 23, 2009, 11:27:59 »

You probably have set the fadeout value to 0 - but yeah, simply attaching the tunes in question to your next post would be helpful.
Logged
» My TMA artist profile
» Visit my music site: https://sagamusix.de/ [de, en]
» Visit my programming website: https://sagagames.de/ [de]
» Open ModPlug Tracker

ant1

  • Devouring the Pies
  • Offline Offline
  • Posts: 16
    • View Profile
    • chiptune most days
Re: Fake note stops?
« Reply #3 on: October 23, 2009, 16:51:25 »

It's working now - thank you both!

I had left the fadeout at its default value of 256, but I just found out it actually goes all the way up to 32000, so 256 doesn't really do much. I'll remember to change it in future. :)

I also found that the volume jump is due to putting the wrong instrument number next to my note offs.

Thanks again for being so helpful, and sorry for asking silly questions!
Logged

m0d

  • Architect v3-4.0b
  • Administrator
  • Lerd of the Pies
  • ****
  • Offline Offline
  • Posts: 1848
  • M0d
    • View Profile
    • http://winter.pics
Re: Fake note stops?
« Reply #4 on: October 23, 2009, 17:06:25 »

Silly question? not at all.

Glad you got sorted, nice one :)
Logged
The Architect 🤔

Saga Musix

  • TMA Moderator
  • Too much pie
  • *****
  • Offline Offline
  • Posts: 2215
  • I love OpenMPT! And Modules! And TMA! And Pie! :>
    • View Profile
    • Saga Musix - free module music and more!
Re: Fake note stops?
« Reply #5 on: October 23, 2009, 20:49:02 »

Actually, fadeout only goes up to 4095 in XM Format, but that limit is no set up correctly in MPT until the latest version. If you want an instant fade-out (note cut), use an envelope (if 4095 is not enough).
Logged
» My TMA artist profile
» Visit my music site: https://sagamusix.de/ [de, en]
» Visit my programming website: https://sagagames.de/ [de]
» Open ModPlug Tracker

ant1

  • Devouring the Pies
  • Offline Offline
  • Posts: 16
    • View Profile
    • chiptune most days
Re: Fake note stops?
« Reply #6 on: October 24, 2009, 02:51:46 »

Ah, okay, thanks! I'll remember that. :)

I mainly stick to .it for Modplug anyway (which I've had no problems with), but I was reworking some MilkyTracker things. Thanks for your help!
Logged
Pages: [1]   Go Up