Mod Archive Forums Mod Archive Forums
Advanced search  

News:

Please note: Your main modarchive.org account will not work here, you must create a forum account to post on the forums.

Pages: [1]   Go Down

Author Topic: Confusing "incompatible pattern data"  (Read 2548 times)

0 Members and 1 Guest are viewing this topic.

argasek

  • Liking the Pie
  • Offline Offline
  • Posts: 2
    • View Profile
Confusing "incompatible pattern data"
« on: November 22, 2014, 18:39:32 »

Hi,

When trying to save emax-seq.mod, I get the "Incompatible pattern data" message. However, all of the conditions mentioned in the message are met:
- Pattern length is exactly 64 rows
- Only notes between C-3 and B-5
- Volume column is not used
- Only effects between 0 and F

What really is the reason, this module uses EFx command, which is not implemented in MT. I'm OK with this, and removing the effect from the patterns saves the file, however the message is confusing. I see two solutions here:
- short term: reword the message so it clearly says "Hey, you are trying to save a file with an unsupported command: %s", %s = command
- long term: implement the EFx command... :)

Cheers, and hats off for your amazing work on MilkyTracker!

J.
Logged

Deltafire

  • Milkytracker Moderator
  • Pie Rehab
  • *
  • Offline Offline
  • Posts: 195
    • View Profile
Re: Confusing "incompatible pattern data"
« Reply #1 on: July 05, 2015, 23:12:30 »

I think the reason this message is being displayed is because the file has notes that are out-of-range for the .mod format (above B-5).  Milkytracker shouldn't have any problems with saving the EFx command.
Logged
Pages: [1]   Go Up