Mod Archive Forums Mod Archive Forums
Advanced search  

News:

Please note: Your main modarchive.org account will not work here, you must create a forum account to post on the forums.

Pages: [1]   Go Down

Author Topic: v1.01.00 playing weirdly on start  (Read 386 times)

0 Members and 1 Guest are viewing this topic.

Hugh

  • Liking the Pie
  • Offline Offline
  • Posts: 3
    • View Profile
v1.01.00 playing weirdly on start
« on: January 12, 2018, 00:31:05 »

So I've loaded a couple of samples, edited one of them. Now when I hit any Play button, MilkyTracker "goes mad".

It MIGHT be sorted if I shut it down and reload it - meaning this could be a real pig to reproduce. I did create another track in v1.01.00 and everything was fine.

https://www.youtube.com/watch?v=SVo6XIlROpw
Logged

Hugh

  • Liking the Pie
  • Offline Offline
  • Posts: 3
    • View Profile
Re: v1.01.00 playing weirdly on start
« Reply #1 on: January 12, 2018, 00:35:31 »

Believe I've reproduced this simply by having a buffer size <256.

Windows x64 by the way.
Logged

Saga Musix

  • TMA Moderator
  • Too much pie
  • *****
  • Offline Offline
  • Posts: 2065
  • I love OpenMPT! And Modules! And TMA! And Pie! :>
    • View Profile
    • Saga Musix - free mod music and more!
Re: v1.01.00 playing weirdly on start
« Reply #2 on: January 12, 2018, 19:00:21 »

YouTube says the video isn't available. However, <256 samples is a rather short buffer size and not every driver type will be able to keep up with such short buffers (not a Milky-specific thing).
Logged
» My TMA artist profile
» Visit my music site: https://sagamusix.de/ [de, en]
» Visit my programming website: https://sagagames.de/ [de]
» Open ModPlug tracker

Hugh

  • Liking the Pie
  • Offline Offline
  • Posts: 3
    • View Profile
Re: v1.01.00 playing weirdly on start
« Reply #3 on: January 12, 2018, 20:37:03 »

OOPS, fixed.

This is a REALLY weird issue given the apparent cause. It's not that the sound skips. The sound was fine - when I had notes in it. The track skips around all over the place. (I removed the notes to see if it changed the behaviour at all - it behaves as if there's some underlying note effects.)
Logged
Pages: [1]   Go Up