Mod Archive Forums Mod Archive Forums
Advanced search  

News:

Please note: Your main modarchive.org account will not work here, you must create a forum account to post on the forums.

Pages: [1] 2   Go Down

Author Topic: Another Modarchive Login Bug  (Read 945 times)

0 Members and 1 Guest are viewing this topic.

Uncertain

  • Devouring the Pies
  • Offline Offline
  • Posts: 14
    • View Profile
Another Modarchive Login Bug
« on: July 19, 2019, 23:37:00 »

Logging into the TMA forums seems to be entering in conflict with the other TMA login. Not sure if that's intended, but it's still something to look at.
Logged

Saga Musix

  • TMA Moderator
  • Too much pie
  • *****
  • Offline Offline
  • Posts: 2262
  • I love OpenMPT! And Modules! And TMA! And Pie! :>
    • View Profile
    • Saga Musix - free module music and more!
Re: Another Modarchive Login Bug
« Reply #1 on: July 23, 2019, 18:10:14 »

Can you please describe how it conflicts for you? I am logged into both accounts at the same time.
Logged
» My TMA artist profile
» Visit my music site: https://sagamusix.de/ [de, en]
» Visit my programming website: https://sagagames.de/ [de]
» Open ModPlug Tracker

Uncertain

  • Devouring the Pies
  • Offline Offline
  • Posts: 14
    • View Profile
Re: Another Modarchive Login Bug
« Reply #2 on: July 24, 2019, 01:49:30 »

Prerequisites:
  • Windows 10
  • Firefox 68.0.1
Steps to reproduce:
Step 1: Login to TMA
Step 2: Login to TMA forums

You are now no longer logged into TMA (not the forums).
Logged

Saga Musix

  • TMA Moderator
  • Too much pie
  • *****
  • Offline Offline
  • Posts: 2262
  • I love OpenMPT! And Modules! And TMA! And Pie! :>
    • View Profile
    • Saga Musix - free module music and more!
Re: Another Modarchive Login Bug
« Reply #3 on: July 24, 2019, 21:32:45 »

It works for me, same system and browser. Do you maybe use any privacy/cookie related extensions?
Logged
» My TMA artist profile
» Visit my music site: https://sagamusix.de/ [de, en]
» Visit my programming website: https://sagagames.de/ [de]
» Open ModPlug Tracker

Uncertain

  • Devouring the Pies
  • Offline Offline
  • Posts: 14
    • View Profile
Re: Another Modarchive Login Bug
« Reply #4 on: July 25, 2019, 00:55:37 »

Do you maybe use any privacy/cookie related extensions?
I use uBlock Origin, HTTPS Everywhere and Cookie AutoDelete.

I also set the privacy.firstparty.isolate option to true in about:config.
Logged

Saga Musix

  • TMA Moderator
  • Too much pie
  • *****
  • Offline Offline
  • Posts: 2262
  • I love OpenMPT! And Modules! And TMA! And Pie! :>
    • View Profile
    • Saga Musix - free module music and more!
Re: Another Modarchive Login Bug
« Reply #5 on: July 25, 2019, 18:52:46 »

Are you opening the forum and front page in two different tabs? Cookie AutoDelete sounds like it could be the culprit because the session cookie would be shared between the two.
Logged
» My TMA artist profile
» Visit my music site: https://sagamusix.de/ [de, en]
» Visit my programming website: https://sagagames.de/ [de]
» Open ModPlug Tracker

Uncertain

  • Devouring the Pies
  • Offline Offline
  • Posts: 14
    • View Profile
Re: Another Modarchive Login Bug
« Reply #6 on: July 26, 2019, 00:35:54 »

I did all the steps listed above in the same tab, since I know how Cookie AutoDelete behaves when closing tabs. Cleanup on domain change isn't enabled either.
Logged

Uncertain

  • Devouring the Pies
  • Offline Offline
  • Posts: 14
    • View Profile
Re: Another Modarchive Login Bug
« Reply #7 on: July 28, 2019, 20:59:07 »

Upon further investigation, I found out that logging into the forums first and then logging to TMA allows you to be logged in on both accounts (but not when logging to TMA first).

I'm not an expert on this, but I suspect this might have something to do with how the PHPSESSID cookie is handled.
Logged

Saga Musix

  • TMA Moderator
  • Too much pie
  • *****
  • Offline Offline
  • Posts: 2262
  • I love OpenMPT! And Modules! And TMA! And Pie! :>
    • View Profile
    • Saga Musix - free module music and more!
Re: Another Modarchive Login Bug
« Reply #8 on: July 28, 2019, 21:47:38 »

I tried to reproduce this in a private window, both first logging into TMA and first logging into the forums and it worked in both cases for me. I too suspect that it's PHPSESSID related, but I cannot find any explanation why it doesn't work for you, unfortunately.
Logged
» My TMA artist profile
» Visit my music site: https://sagamusix.de/ [de, en]
» Visit my programming website: https://sagagames.de/ [de]
» Open ModPlug Tracker

Saga Musix

  • TMA Moderator
  • Too much pie
  • *****
  • Offline Offline
  • Posts: 2262
  • I love OpenMPT! And Modules! And TMA! And Pie! :>
    • View Profile
    • Saga Musix - free module music and more!
Re: Another Modarchive Login Bug
« Reply #9 on: August 04, 2019, 16:03:05 »

I modified the session handling a bit - maybe it works better for you now.
Logged
» My TMA artist profile
» Visit my music site: https://sagamusix.de/ [de, en]
» Visit my programming website: https://sagagames.de/ [de]
» Open ModPlug Tracker
Pages: [1] 2   Go Up