Mod Archive Forums Mod Archive Forums
Advanced search  

News:

Please note: Your main modarchive.org account will not work here, you must create a forum account to post on the forums.

Pages: [1]   Go Down

Author Topic: [confirmed?] saving as MOD problem  (Read 3602 times)

0 Members and 1 Guest are viewing this topic.

am-fm

  • Devouring the Pies
  • Offline Offline
  • Posts: 19
    • View Profile
    • http://www.surprise-productions.com
[confirmed?] saving as MOD problem
« on: August 09, 2007, 01:59:35 »

yo,

i noticed, that milky "fucks" up the loop points when i save my song as a MOD... is this normal or a bug??
« Last Edit: January 06, 2009, 12:54:54 by m0d »
Logged
Surprise ! Productions - drunk like hell since 1991
The Ravebusters - Bumping ya ears since 1987

raina

  • Milkytracker Moderator
  • Url of Pieland
  • ***
  • Offline Offline
  • Posts: 718
    • View Profile
    • raina.kapsi.fi
Use 0, 2, 4, 6, 8, A, C & E not 1, 3, 5, 7, 9, B, D, F
« Reply #1 on: August 09, 2007, 07:05:57 »

Yes, this is intentional and probably the most important feature of the tracker. The art of "f***ing" up... Enough silliness! Do you mean the loop points are shifted to even values? MODs can't have odd size samples and apparently it applies to loop point places too. A quick scan through random MODs seems to suggest this as well.

jimee

  • Devouring the Pies
  • Offline Offline
  • Posts: 19
    • View Profile
Re: saving as MOD problem
« Reply #2 on: August 09, 2007, 10:25:11 »

I confirm that the 68k (hehe, amiga forever!) has a 16 bits data bus, and an address bus that can only manage even addresses. Odd addresses are accessed by using a special pin of the 68k. All other chips (sound, video) can only use even addresses. So, in MOD format, samplelen loopstart and looplen are always even values. And to get confused a little, these values are written without the last 0 bit! (That means, the values are divided by 2).

A little word about amiga loops: if loopstart=0, the sample is played entierely before starting the loop. That is a special "feature" because the amiga sound processor cant disable loop. Samples with no loop are identified by loopstart=0, looplen=2, and sampledata starting with 2 null bytes. If you dont start the sampledata with 2 null bytes, amiga will play an awful acute sound at the end of the sample.
Logged

Saga Musix

  • TMA Moderator
  • Too much pie
  • *****
  • Offline Offline
  • Posts: 2296
  • I love OpenMPT! And Modules! And TMA! And Pie! :>
    • View Profile
    • Saga Musix - free module music and more!
Re: saving as MOD problem
« Reply #3 on: August 09, 2007, 13:45:38 »

wee, amigas are complicated ;D i never noticed such things when converting my modules... but that's probably only coz i never played em on a real amiga :D
Logged
» My TMA artist profile
» Visit my music site: https://sagamusix.de/ [de, en]
» Visit my programming website: https://sagagames.de/ [de]
» Open ModPlug Tracker
Pages: [1]   Go Up