Mod Archive Forums Mod Archive Forums
Advanced search  

News:

Please note: Your main modarchive.org account will not work here, you must create a forum account to post on the forums.

Pages: [1]   Go Down

Author Topic: "Jump" button buggy  (Read 4022 times)

0 Members and 1 Guest are viewing this topic.

angelfarto

  • Wants more Pie
  • Offline Offline
  • Posts: 8
    • View Profile
"Jump" button buggy
« on: August 26, 2007, 20:42:00 »

Say you're viewing 50 per page in the S archive:

http://modarchive.org/browse.php?method=byletter&query=S&limit=50&page=1

and then want to jump to page 162.

It will go to page 162 sure. But it'll reset the show per page # back to 20!!

Very annoying while browsing large amounts of files!

and if you want to set 'show per page' back to 50, it goes to page 1!! (which is understandable. but still ><! )
Logged

m0d

  • Architect v3-4.0b
  • Administrator
  • Lerd of the Pies
  • ****
  • Offline Offline
  • Posts: 1851
  • Created modarchive.org entirely in bloody vim!
    • View Profile
    • RedHeat
Re: "Jump" button buggy
« Reply #1 on: August 27, 2007, 11:00:10 »

Fixed. I am still *on vacation*.

Quote
and if you want to set 'show per page' back to 50, it goes to page 1!! (which is understandable. but still ><! )

This is deliberate, because you will get a blank page or an error if you switch to a page amount which makes the current page number higher than the actual amount available if you switch to say, 100 per page from 20 (e.g you wouldd be on page 600, when the highest amount available in 100 per page view is 250, thus no results returned)

I'll be going back to my vacation now. :)
Logged
Created modarchive.org entirely in bloody vim!

angelfarto

  • Wants more Pie
  • Offline Offline
  • Posts: 8
    • View Profile
Re: "Jump" button buggy
« Reply #2 on: August 28, 2007, 20:04:36 »

now that's service.  :-*
Logged
Pages: [1]   Go Up