Mod Archive Forums Mod Archive Forums
Advanced search  

News:

Please note: Your main modarchive.org account will not work here, you must create a forum account to post on the forums.

Pages: [1]   Go Down

Author Topic: Samples not playing at correct frequency  (Read 2692 times)

0 Members and 1 Guest are viewing this topic.

a9642

  • Wants more Pie
  • Offline Offline
  • Posts: 8
    • View Profile
Samples not playing at correct frequency
« on: December 14, 2009, 05:21:57 »

Hi. I just downloaded Milky Tracker earlier this week. I've been using Mad Tracker off and on for a year now with little to no success, and thought this tracker might be more of what I'm looking for (specifically the sample creating and editing features). So I downloaded it, read the starting tutorial up to the point where it talks about editing samples, and try to make one.

I right-clicked the sample editor and made a new sample, choosing to make it 22050 samples long. (I'm guessing MilkyTracker plays samples at 22050Hz, as this sample lasts 1sec when I play it.)

I then right-clicked again and generated some square waves, 440 of them, to be exact. With 440 waves in one second, I expected that MilkyTracker would play the note "A" when I hit play.

Instead, I heard a note which was definitely note A. I noticed the buttons that change the note at which the sample is played back, and tried fiddling with those both before and after I generate my sample, but I can't get it to generate the proper note. (It seems to be generating a note about a 5th higher).

What am I doing wrong? How can I just generate a sample that's 1 second long and has 440 square waves?
« Last Edit: December 14, 2009, 05:50:25 by a9642 »
Logged

Deltafire

  • Milkytracker Moderator
  • Pie Rehab
  • *
  • Offline Offline
  • Posts: 193
    • View Profile
Re: Samples not playing at correct frequency
« Reply #1 on: December 14, 2009, 13:42:50 »

Have a read through this thread.

Basically, the samples are played back at 8363Hz (with no transpose/fine-tuning applied), so for a C-4 note you will want to create a new sample with a length of 32 - this way you will only need to draw (and store) one period of the waveform - remember to enable looping!

To ensure the sample only lasts for 1 second, you would use the envelope tool in the instrument editor.
Logged

a9642

  • Wants more Pie
  • Offline Offline
  • Posts: 8
    • View Profile
Re: Samples not playing at correct frequency
« Reply #2 on: December 14, 2009, 23:33:14 »

Thanks for the link. I've followed the advice there and have been able to get some little songs going. This is more progress then I ever got with MadTracker. If you don't mind my asking more questions in this thread:

I've noticed that some of my samples start to sound out of tune when they get further away from their "natural" note (the note I originally created the sample at). What's the best way to reduce this effect? And is it possible to load multiple samples in the same instrument, and specify that one should be used around the 5th octave, while another is for the 4th?

I've looked online and searched the forums here, but I don't see the option for changing the octave of notes as I place them (so that a note will be placed as "c-2" instead of "c-4" when I press the Z key).

Thanks again for the help so far.
Logged

DasKreestof

  • Pie Addict
  • Offline Offline
  • Posts: 59
    • View Profile
Re: Samples not playing at correct frequency
« Reply #3 on: December 15, 2009, 00:00:03 »

A limitation of conventional sampling compared to granular synthesis is that the harmonics of a sample change as you get further from the original sample.  In sampling the work around is indeed to use multiple samples mapped across the keyboard. In the early 90s I remember a good sampling practice was to use 2-4 samples per octave as needed based on your preferences. (ram was very limited then.) You could stretch a sample more, but the effect could be undesired. Today in modern softsamplers, it is not uncommon to have one sample per note, especially for pianos.)

In Milkytracker, the resampler you use will effect the quality of the sound as you move further from the root note. I have read that the linear resampler is the most accurate.

You can place more than one sample in an instrument, called a multisampled instrument. This is done in the Instrument editor. You will select the ranges that each sample occupies across the range of the keyboard. The ranges cannot overlap because instruments in tracking are monophonic. (one voice at a time)

You will designate the placement of the notes on the keyboard by selecting the sample pressing edit, and then selecting the notes you want the sample to be on. The octave of the sample in the multisample is selected under relative note.
Logged
Pages: [1]   Go Up